Bazaar

Bazaar

 




Wiki Tools

  • Find Page
  • Recent Changes
  • Page History
  • Attachments

Home |

In Brief

To Install from the Eclipse Marketplace, drag and drop this button into a running Eclipse Indigo workspace.

http://marketplace.eclipse.org/marketplace-client-intro?mpc_install=944882

For people familiar with the installation of Eclipse plugins, here are the update sites:

Prerequisites

In order to use bzr-eclipse, you need to have installed:

bzr-eclipse has no special system requirements beyond those of Bazaar and Eclipse.

Installation

Within Eclipse 4.2 Juno

  1. Go to *Help* --> *Install New Software*
    Eclipse shows a new dialog.

  2. Click *Add* at the top right
    Eclipse shows another new, small dialog

  3. Provide the *Name*: "bzr-eclipse update-site"; *Location*: "http://bzreclipse.org/update-site/" and click *OK*.
    Eclipse returns to the first dialog, searches for the update site, and populates the central information area with the feature name *Collaboration*

  4. Click *Select All* to select the bzr-eclipse plugin, then *Next* at the bottom.
    Eclipse shows the *Install Details* page.

  5. Click *Next*
    Eclipse shows the *Review Licensese* page.

  6. Click *I accept . . .*; then *Finish*
    Eclipse shows some dialogs, including a warning message about unsigned content.

  7. Click *OK* to accept the unsigned content.
    Eclipse does some more work, and then requests a restart.

  8. Accept the Eclipse Restart, then wait
    Eclipse starts up again, and the plugin is installed.

Within Eclipse 4.3 Kepler

Those for 4.2 Juno above should be sufficient, but there might be slight variance.

Using Eclipse Marketplace

Instructions coming soon.

Required Configuration

  1. Go to: Window --> Preferences --> Team --> Bazaar.

  2. Ensure that the path to the bzr executable is correct for your system.
  3. Enter your name (and optionally email address) as you want it to appear in your commits.
    • attachment:Preferences_Bazaar.png

Fetching a Project

To fetch an existing project stored in Bazaar:

  • Go to: *File* --> *New* --> *Project*<<BR>Eclipse opens the new project dialog

  • Under *Bazaar* select *Project From Bazaar* and click *Next*.
    Eclipse shows the *Eclipse Project From Bazaar* dialog.

  • Provide your Bazaar URL, project name and location, then click *Next* to get to the advanced page.
  • Change any required advanced selections, and click *Finish* to fetch the project.
    bzr-eclipse options are now found in the team menu and under Compare With.

Starting a New Project

  • Open a project in Eclipse
  • Go to 'Team - Share Project...' in the project's Explorer context menu
  • Select the Bazaar repository type if necessary.
  • In the 'Connect to an existing bazaar version control' dialog specify the folder containing the Bazaar project
  • After this you'll find the supported Bazaar actions in the 'Team' menu in the project's Explorer context menu.

Authentication

To access branches that require public key authentication:

  1. run a ssh-agent and load the public keys before the first access.
  2. install ssh-askpass or similar software (this option can be used with an ssh-agent)

Optional Configuration

  • To activate icon decorators go to: Preferences --> General --> Appearance --> Label Decorations and check Bazaar.

    • attachment:IconDecorator.png

  • To activate text decorators go to: Preferences --> Team --> Bazaar --> Text Decorators

    • attachment:TextDecorator.png

  • Customize console output: Preferences --> Team --> Bazaar --> Console

    • attachment:ConsoleOptions.png

Old Eclipse Instructions

These instructions applied to earlier versions of Eclipse.

  1. Go to *Help* --> *Software updates* --> *Find and install*

    • attachment:Help_FindAndInstall.png

  2. Select *Search for new features to install* and then --> *Next*

    • attachment:Feature_Update.png

  3. Click *New remote site*.
  4. In the name field, enter i.e: *Bazaar plugin for Eclipse* and in the URL field: http://bazaar-vcs.org/releases/3rd-party/bzr-eclipse/ or http://verterok.com.ar/bzr-eclipse/update-site/

    • attachment:update_sites_to_visit.png

  5. Verify that the checkbox for the new update site is checked, and click *Finish*
  6. A dialog with the results should pop-up.
    • attachment:UpdateSite_searchResults.png

  7. Select the latest version inside *bzr-eclipse (actual)*
  8. Click *Finish*, and this will launch a wizard (license agreement, etc).
  9. Restart Eclipse. Make sure to restart it with "-clean" switch